Select Page

Fortinet has warned of a high-severity flaw affecting multiple versions of FortiADC application delivery controller that could lead to the execution of arbitrary code.

“An improper neutralization of special elements used in an OS command vulnerability in FortiADC may allow an authenticated attacker with access to the web GUI to execute unauthorized code or commands via specifically crafted HTTP requests,” the company¬†said in an advisory.

The vulnerability, tracked as CVE-2022-39947 (CVSS score: 8.6) and internally discovered by its product security team, impacts the following versions –

  • FortiADC version 7.0.0 through 7.0.2
  • FortiADC version 6.2.0 through 6.2.3
  • FortiADC version 6.1.0 through 6.1.6
  • FortiADC version 6.0.0 through 6.0.4
  • FortiADC version 5.4.0 through 5.4.5

Users are recommended to upgrade to FortiADC versions 6.2.4 and 7.0.2 as and when they become available.

images from Hacker News